Page 1 of 1

[FTEQW][FIXED]Particles are being difficult

PostPosted: Mon Feb 02, 2015 8:33 am
by jjsullivan5196
[FIXED] Spike is working on it, turns out this is a bug

[FIXED2] It's fully working now, just as I have it here. If you're running into trouble, upgrade to the latest build!

Hi there, I was trying to get this solved with Spike's help in the irc before, I got a little ways down the road but now I'm stuck again.

I'm trying to figure out how to do custom particles in FTEQW (More specifically in CSQC), the problem is that I keep trying to use a custom particle set and it keeps on not wanting to show me anything.

I've gotten as far as receiving an event from the server to create a particle effect and display it in the client renderer, this works fine with the classic particle set built into FTE. However, even if I specifically register a particle effect with particleeffectnum(); it still doesn't want to show anything.

For example, I've been trying to use haze's particle set as a test. In CSQC_Init(); , I put the following:

Code: Select all
TE_ESPLODE = particleeffectnum("haze.te_explode");

This precaches the effect and stores its handle to TE_ESPLODE, all well and good. The console even reassures me that haze.cfg is active. Here's where the mess happens (in CSQC_Parse_Event();):

Code: Select all
pointparticles(TE_ESPLODE, loc);

This is linked to an event that recognizes that a shot has landed, when it does, this effect plays. I can confirm that the code itself works because with the classic particle set, all is good, I can see an explosion. But when I set r_particlesdesc to haze, that all goes out the window. When I restart the map with it set to classic, it somehow works like magic, but with a whole lot more classic quake particles.

Does anybody know how I can get my custom esplosions?