Page 2 of 4

Re: PCem

PostPosted: Sun Oct 05, 2014 6:19 am
by revelator
You can use this with virtualbox its a bit slow though.

supports win 95 also :)

heres a howto

Re: PCem

PostPosted: Sun Oct 05, 2014 11:48 am
by leileilol
mankrip wrote:What I want is to use old tools like AdQuedit (which doesn't run properly on anything newer than XP) and to install a Linux distro.

For vintage Win9X tool use i'd just use VirtualPC 2007 since that can use virtualization and has drivers for Win9X, as well as drag and drop (kind of an important thing regarding workflow). Ignore the "not supported host OS!" stuff, works fine in 7 x64 for me.

It even has undo disks so if adquedit nukes your files it's no problem to undo! (also btw..... why adquedit?)

Re: PCem

PostPosted: Sun Oct 05, 2014 8:23 pm
by revelator
Might be he was used to working with it :) last version was free but im not sure the source code was ever released ? if it was and someone has it i could try and port it over to newer OS.
Many old tools where really nice but newer got updated for post win9x though some work when using compatibility settings, one of my favorites (norton commander) has luckily had many clones,
sadly norton navigator was newer updated and does not work on anything newer than win 95 (believe me i tried everything).

Re: PCem

PostPosted: Tue Oct 07, 2014 3:09 am
by revelator
Tried pcem and a few remarks.

was missing libgcc dependency so did not work first time.
configure menu is not working.

i recompiled it with my own compiler that defaults to linking statically to the gcc runtimes.
this is not a problem, in case you want to debug it cause my compiler was patched to allow throwing exceptions from the static libraries).

used latest OpenAL and Alut.

included all roms from the pcem site.

pcem now has an icon.

Re: PCem

PostPosted: Wed Oct 08, 2014 4:43 pm
by revelator
the broken configure menu seems to be a bug in pcem's resource script,
it refuses to compile unless i run it through a resource editor to rearrange some of the defines but that breaks the configure menu :S
i have a hunch that the pcem builder uses an archaic mingw version with a really old windres cause the newer ones from 2.23 and up dont accept the resource scripts.
Sadly there are not many resource editors avaliable for mingw, i used resed from radasm but i tried with resedit also and both break the config menu so it seems there is a bug in the rc.

Re: PCem

PostPosted: Wed Oct 08, 2014 5:10 pm
by leileilol
PCem's configure menu works in my mingw compiles.

Re: PCem

PostPosted: Wed Oct 08, 2014 5:35 pm
by revelator
Yeah it seems to be related to the binutils version used, i tried with an older one and now it works.
So seems i have to file a bugreport to the binutils mantainers.

final build here

compiled with sse3 optimization and core2 machine instructions, linked statically to the libstdc++ and libgcc libraries so the only dll dependencies are libalut and OpenAL32.

If you need a version compiled for a lower end machine ill make one, just wanted to see if the optimizations would have any effect.

Re: PCem

PostPosted: Wed Oct 08, 2014 7:06 pm
by revelator
Well this is the code piece it breaks on

Code: Select all

command windres.exe -i pc.rc --input-format=rc -o pc.res -O coff --use-temp-file

windres.exe: pc.rc:72: syntax error hmm ??? i wonder if the empty "" is whats causing newer windres to go bonkers.

Re: PCem

PostPosted: Thu Oct 09, 2014 4:53 am
by leileilol
revelator wrote:compiled with sse3 optimization and core2 machine instructions,

sadly, this crashes on my AMD.

Re: PCem

PostPosted: Thu Oct 09, 2014 6:38 am
by revelator
Ok ill upload a few other pcem builds with optimization for AMD :)

Re: PCem

PostPosted: Thu Oct 09, 2014 7:00 am
by revelator

AMD builds covers pretty much all archs even the embedded ones.

Re: PCem

PostPosted: Thu Oct 09, 2014 12:04 pm
by revelator
fixed the rc error need to include
#include <commctrl.h>
just below
#include <windows.h>
mingw version that was used to build pcem used an earlier win32api which did not have this requirement.
works now also with the latest gcc and binutils :)

Re: PCem

PostPosted: Thu Oct 09, 2014 1:00 pm
by leileilol
Running with opteron-sse3 causes Windows 98SE to crash its video driver in a text mode with a bunch of repeating characters

Running Q3Ademo on Q3DM17 with AM486DX4/120 and infinite cache, here's the execution percentages i'm getting of a 320x240 ~3fps scene

Original release - 79%
Athlon - 67%
AthlonXP - 67%
Barcelona = 67%
Geode = 68%
Opteron = 72%
Opteron SSE3 = 70%

somehow i'm doubting the usefulness of automatic optimization

Re: PCem

PostPosted: Thu Oct 09, 2014 1:21 pm
by revelator
Not automatic just toyed a bit with the different cpu models various optimizations, does not help a bit though if the code cant make use of features like say SSE either because its not coded for that or incompatible.

64 bit build and yes it works :) actually only one place where the 64 bit compiler says no and its in resid-fp not in PCem itself, so i had to compile with -fpermissive to create it but it seems to work so far
(might not work on AMD its compiled with intel instructions). Ill make one for AMD also.

i also created a codeblocks project for the source, the maintainer is welcome to use it.

Re: PCem

PostPosted: Thu Oct 09, 2014 2:35 pm
by revelator
Cleaned up the code some and fixed a bug in the audio library (OpenAL).
Also fixed some compiler warnings about functions with no default type and some typecast problems.
Still needs work but its heaps better allready.

Built with standard I686 machine type so should work on all processors.

btw how do you install say win98 in this if you dont have the cd anymore ? i got iso backups of all my windows versions but PCem seems to be unable to boot from cd with the roms i could find.